Announcement

Collapse
No announcement yet.

Magento 2.1.8 Reindex Timeout

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Magento 2.1.8 Reindex Timeout

    We have a Magento store that we upgraded to 2.1.8 last week. Everything seemed to be working well till then. However, after the update, I am no longer able to re-index Category Products and Product Categories. The others indexes run fine. We have added more products since then too, however, it seems like too much of a coincidence that this would stop working right after the update.



    I have searched for an answer since last week and applied many different solutions, however nothing seems to have fixed this issue. We did not install any new extensions.



    The server specs are as follows:
    • Managed VPS
    • Dedicated CPU: 2 cores, Xeon E5-2630 @ 2.30GHz
    • Dedicated RAM: 6 GB
    • Dedicated Storage: 100 GB on SSD
    • Monthly Data Transfer: 5000 GB (We launched this store 3 months ago, and right now do not have a lot of traffic.)

    Things I have done: (I run reindex from SSH):



    1) Increased php memory limit to 800MB.

    2) Increased the Apache and FastCGI timeout limits to 900 seconds.

    3) Increased the memory and CPU limits for SSH:
    • USER_MAX_CPU_SECS=900
    • USER_MAX_VIRT_MEM=800000
    • USER_MAX_RES_MEM=800000

    4) I reset all indexes and ran reindex again. It did not work:
    • php bin/magento indexer:reset
    • php bin/magento indexer:reindex

    5) I tried running them one by one:
    • php bin/magento indexer:reset catalog_category_product
    • php bin/magento indexer:reset catalog_product_category

    I have run out of ideas and would greatly appreciate any advice and help. Thank you very much in advance.
Working...
X