Announcement

Collapse
No announcement yet.

Making a directory on server private

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Making a directory on server private

    I’m trying to create a private directory on my website.
    Using the following in an .htacess:
    AuthType Basic
    AuthName
    "restricted area"
    AuthUserFile /home/mywebsite/public_html/magmi/.htpasswd
    require valid-user
    And the following for the .htpasswd:
    user_name:password
    I tried storing the files in my root directory and the magmi directory. When storing them at the root level a user authentication is required for every page on website. When storing them in magmi directory, that directory completely disappears. Am I doing something wrong or are there additional server settings that need to be changed. Thanks in advance for the help!

  • #2
    Hello,

    User and password should be created with tool htpasswd.
    So in file /home/mywebsite/public_html/magmi/.htpasswd
    password must be stored as an encrypted one, not plain.
    Also, mind apache configuration and rewrite-rules, it can be the reason of "folder dissappearing"

    Comment


    • #3
      Thankyou Nadezhda for sharing such useful info. From many days, I was also looking for making a directory on server private. I definitely try these steps.

      Comment


      • #4
        How to create username and password ??what tool i have to use?

        Comment

        Working...
        X